import re
regex = re.compile(r"Language:\s*(\w+)\s*Place:\s*HK")
test_str = (" Language: English\n\n"
" Place: Seattle\n\n"
" Segments: b,p,m,d,t\n\n\n"
" Language: Mandarin\n\n"
" Place: HK\n\n"
" Segments: n,i,o,h\n\n\n"
" Language: Cantonese\n\n"
" Place:HK\n\n"
" Segments:l,e,h,o")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")