package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Language:\s*(\w+)\s*Place:\s*HK`)
var str = ` Language: English
Place: Seattle
Segments: b,p,m,d,t
Language: Mandarin
Place: HK
Segments: n,i,o,h
Language: Cantonese
Place:HK
Segments:l,e,h,o`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}