using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Language:\s*(\w+)\s*Place:\s*HK";
string input = @" Language: English
Place: Seattle
Segments: b,p,m,d,t
Language: Mandarin
Place: HK
Segments: n,i,o,h
Language: Cantonese
Place:HK
Segments:l,e,h,o";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}