re = /Language:\s*(\w+)\s*Place:\s*HK/
str = ' Language: English
Place: Seattle
Segments: b,p,m,d,t
Language: Mandarin
Place: HK
Segments: n,i,o,h
Language: Cantonese
Place:HK
Segments:l,e,h,o'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end