// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Language:\s*(\w+)\s*Place:\s*HK").unwrap();
let string = " Language: English
Place: Seattle
Segments: b,p,m,d,t
Language: Mandarin
Place: HK
Segments: n,i,o,h
Language: Cantonese
Place:HK
Segments:l,e,h,o";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}