using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(title=)""?[^""\s]*""?(.*) name=""?([^""\s]+)""?";
string substitution = @"$1""$3""$2";
string input = @"title=""alpha"" lorem ipsum lorem ipsum name=""beta""
title=""omega"" Morbi posuere metus purus name=""delta""
title=""alpha"" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}