// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?"#).unwrap();
let string = "title=\"alpha\" lorem ipsum lorem ipsum name=\"beta\"
title=\"omega\" Morbi posuere metus purus name=\"delta\"
title=\"alpha\" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta";
let substitution = "$1\"$3\"$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}