import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(title=)\"?[^\"\\s]*\"?(.*) name=\"?([^\"\\s]+)\"?";
final String string = "title=\"alpha\" lorem ipsum lorem ipsum name=\"beta\"\n"
+ "title=\"omega\" Morbi posuere metus purus name=\"delta\"\n"
+ "title=\"alpha\" lorem ipsum lorem ipsum name=beta\n"
+ "title=alpha lorem ipsum lorem ipsum name=beta";
final String subst = "$1\"$3\"$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}