use strict;
my $str = 'title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"
title="alpha" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta';
my $regex = qr/(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?/mp;
my $subst = '$1"$3"$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";