package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?`)
var str = `title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"
title="alpha" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta`
var substitution = "$1"$3"$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}