re = /(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?/m
str = 'title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"
title="alpha" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta'
subst = '$1"$3"$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result