import Foundation
let pattern = #"(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"
title="alpha" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$3"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)