const regex = /(title=)"?[^"\s]*"?(.*) name="?([^"\s]+)"?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(title=)"?[^"\\s]*"?(.*) name="?([^"\\s]+)"?', 'gm')
const str = `title="alpha" lorem ipsum lorem ipsum name="beta"
title="omega" Morbi posuere metus purus name="delta"
title="alpha" lorem ipsum lorem ipsum name=beta
title=alpha lorem ipsum lorem ipsum name=beta`;
const subst = `$1"$3"$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);