#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)"
Local $sString = "* Lorem" & @CRLF & _
"* Lorem" & @CRLF & _
"* Lorem" & @CRLF & _
"* Lorem" & @CRLF & _
"*" & @CRLF & _
"+ Lorem" & @CRLF & _
"- Dolor" & @CRLF & _
"• Sit" & @CRLF & _
"‣ Lorem" & @CRLF & _
"⁃ Ipsum" & @CRLF & _
"" & @CRLF & _
"*No Match" & @CRLF & _
"o No Match" & @CRLF & _
"0 No Match" & @CRLF & _
"? No Match" & @CRLF & _
"` No Match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")