import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([-+*\\x{2022}\\x{2023}\\x{2043}])(?:\\s+|$)";
final String string = "* Lorem\n"
+ "* Lorem\n"
+ "* Lorem\n"
+ "* Lorem\n"
+ "*\n"
+ "+ Lorem\n"
+ "- Dolor\n"
+ "• Sit\n"
+ "‣ Lorem\n"
+ "⁃ Ipsum\n\n"
+ "*No Match\n"
+ "o No Match\n"
+ "0 No Match\n"
+ "? No Match\n"
+ "` No Match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}