re = /^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)/m
str = '* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
` No Match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end