using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)";
string input = @"* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
` No Match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}