const regex = /^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([-+*\\x{2022}\\x{2023}\\x{2043}])(?:\\s+|$)', 'gm')
const str = `* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
\` No Match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}