// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)").unwrap();
let string = "* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
` No Match";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}