$re = '/^([-+*\x{2022}\x{2023}\x{2043}])(?:\s+|$)/m';
$str = '* Lorem
* Lorem
* Lorem
* Lorem
*
+ Lorem
- Dolor
• Sit
‣ Lorem
⁃ Ipsum
*No Match
o No Match
0 No Match
? No Match
` No Match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);