using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z()/]";
string substitution = @"";
string input = @"/Date(123456789)/
Agora não considera mais esses caracteres: []^\_
e não remove os espaços: 1234 567";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}