use strict;
my $str = '/Date(123456789)/
Agora não considera mais esses caracteres: []^\\_
e não remove os espaços: 1234 567';
my $regex = qr/[a-zA-Z()/]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";