const regex = /[a-zA-Z()/]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z()\/]', 'gm')
const str = `/Date(123456789)/
Agora não considera mais esses caracteres: []^\\_
e não remove os espaços: 1234 567`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);