# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/aaa(?=[^<]*<\\/?br\s*\\/?>)/<FONT face='monospace' color='black'>$&<\/FONT>/gm;t' <<< "<FONT color='red'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>"