import Foundation
let pattern = #"aaa(?=[^<]*<\/?br\s*\/?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<FONT color='red'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<FONT face='monospace' color='black'>$&</FONT>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)