import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "aaa(?=[^<]*<\\/?br\\s*\\/?>)";
final String string = "<FONT color='red'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>";
final String subst = "<FONT face='monospace' color='black'>$&</FONT>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}