using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"aaa(?=[^<]*<\/?br\s*\/?>)";
string substitution = @"<FONT face='monospace' color='black'>$&</FONT>";
string input = @"<FONT color='red'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}