re = /aaa(?=[^<]*<\/?br\s*\/?>)/m
str = '<FONT color=\'red\'>aaa-1/2</br>bbb-1/3</br>aaa-1/20</FONT>'
subst = '<FONT face=\'monospace\' color=\'black\'>$&</FONT>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result