#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)([a-zA-Z]+\$ \d+,\d+)" & @CRLF & _
"|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)" & @CRLF & _
""
Local $sString = "R$ 0,0" & @CRLF & _
"R$ 0,009" & @CRLF & _
"R$ 1,000" & @CRLF & _
"R$ 0,0056" & @CRLF & _
"R$ 123,00" & @CRLF & _
"R$ 1234,00" & @CRLF & _
"R$ 1.000,00" & @CRLF & _
"R$ 10.000,06" & @CRLF & _
"R$ 100.000,00" & @CRLF & _
"R$ 1.000.000,00" & @CRLF & _
"R$ 10.000.000,00" & @CRLF & _
"R$ 100.000.000,00" & @CRLF & _
"R$ 1.000.000.000,00" & @CRLF & _
"R$ 10.000.000.000,00" & @CRLF & _
"R$ 100.000.000.000,00" & @CRLF & _
"R$ 100.000.000.000,00" & @CRLF & _
"R$ 1.000.000.000.000,00" & @CRLF & _
"R$ 100.000.000.000.000,00" & @CRLF & _
"R$ 1.000.000.000.000.000,00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")