import re
regex = re.compile((r"([a-zA-Z]+\$ \d+,\d+)\n"
r"|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)\n"), flags=re.MULTILINE | re.IGNORECASE)
test_str = ("R$ 0,0\n"
"R$ 0,009\n"
"R$ 1,000\n"
"R$ 0,0056\n"
"R$ 123,00\n"
"R$ 1234,00\n"
"R$ 1.000,00\n"
"R$ 10.000,06\n"
"R$ 100.000,00\n"
"R$ 1.000.000,00\n"
"R$ 10.000.000,00\n"
"R$ 100.000.000,00\n"
"R$ 1.000.000.000,00\n"
"R$ 10.000.000.000,00\n"
"R$ 100.000.000.000,00\n"
"R$ 100.000.000.000,00\n"
"R$ 1.000.000.000.000,00\n"
"R$ 100.000.000.000.000,00\n"
"R$ 1.000.000.000.000.000,00\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")