// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([a-zA-Z]+\$ \d+,\d+)
|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)
").unwrap();
let string = "R$ 0,0
R$ 0,009
R$ 1,000
R$ 0,0056
R$ 123,00
R$ 1234,00
R$ 1.000,00
R$ 10.000,06
R$ 100.000,00
R$ 1.000.000,00
R$ 10.000.000,00
R$ 100.000.000,00
R$ 1.000.000.000,00
R$ 10.000.000.000,00
R$ 100.000.000.000,00
R$ 100.000.000.000,00
R$ 1.000.000.000.000,00
R$ 100.000.000.000.000,00
R$ 1.000.000.000.000.000,00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}