const regex = /([a-zA-Z]+\$ \d+,\d+)
|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+\\$ \\d+,\\d+)
|([a-zA-Z]+\\$ (?:\\d{1,3}\\.)*\\d{3},\\d+)
', 'gmi')
const str = `R\$ 0,0
R\$ 0,009
R\$ 1,000
R\$ 0,0056
R\$ 123,00
R\$ 1234,00
R\$ 1.000,00
R\$ 10.000,06
R\$ 100.000,00
R\$ 1.000.000,00
R\$ 10.000.000,00
R\$ 100.000.000,00
R\$ 1.000.000.000,00
R\$ 10.000.000.000,00
R\$ 100.000.000.000,00
R\$ 100.000.000.000,00
R\$ 1.000.000.000.000,00
R\$ 100.000.000.000.000,00
R\$ 1.000.000.000.000.000,00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}