import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+\\$ \\d+,\\d+)\n"
+ "|([a-zA-Z]+\\$ (?:\\d{1,3}\\.)*\\d{3},\\d+)\n";
final String string = "R$ 0,0\n"
+ "R$ 0,009\n"
+ "R$ 1,000\n"
+ "R$ 0,0056\n"
+ "R$ 123,00\n"
+ "R$ 1234,00\n"
+ "R$ 1.000,00\n"
+ "R$ 10.000,06\n"
+ "R$ 100.000,00\n"
+ "R$ 1.000.000,00\n"
+ "R$ 10.000.000,00\n"
+ "R$ 100.000.000,00\n"
+ "R$ 1.000.000.000,00\n"
+ "R$ 10.000.000.000,00\n"
+ "R$ 100.000.000.000,00\n"
+ "R$ 100.000.000.000,00\n"
+ "R$ 1.000.000.000.000,00\n"
+ "R$ 100.000.000.000.000,00\n"
+ "R$ 1.000.000.000.000.000,00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}