import Foundation
let pattern = #"""
([a-zA-Z]+\$ \d+,\d+)
|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
R$ 0,0
R$ 0,009
R$ 1,000
R$ 0,0056
R$ 123,00
R$ 1234,00
R$ 1.000,00
R$ 10.000,06
R$ 100.000,00
R$ 1.000.000,00
R$ 10.000.000,00
R$ 100.000.000,00
R$ 1.000.000.000,00
R$ 10.000.000.000,00
R$ 100.000.000.000,00
R$ 100.000.000.000,00
R$ 1.000.000.000.000,00
R$ 100.000.000.000.000,00
R$ 1.000.000.000.000.000,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)