package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([a-zA-Z]+\$ \d+,\d+)
|([a-zA-Z]+\$ (?:\d{1,3}\.)*\d{3},\d+)
`)
var str = `R$ 0,0
R$ 0,009
R$ 1,000
R$ 0,0056
R$ 123,00
R$ 1234,00
R$ 1.000,00
R$ 10.000,06
R$ 100.000,00
R$ 1.000.000,00
R$ 10.000.000,00
R$ 100.000.000,00
R$ 1.000.000.000,00
R$ 10.000.000.000,00
R$ 100.000.000.000,00
R$ 100.000.000.000,00
R$ 1.000.000.000.000,00
R$ 100.000.000.000.000,00
R$ 1.000.000.000.000.000,00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}