#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!test).)*$"
Local $sString = "hello there" & @CRLF & _
"hello there test" & @CRLF & _
"testing here " & @CRLF & _
"we are not TEsting here" & @CRLF & _
"hello hi " & @CRLF & _
"this regex captures only thos lines which doenot contain word "TEST" in small caps" & @CRLF & _
"this regex captures only thos lines which doenot contain word "test" in small caps"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")