import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!test).)*$";
final String string = "hello there\n"
+ "hello there test\n"
+ "testing here \n"
+ "we are not TEsting here\n"
+ "hello hi \n"
+ "this regex captures only thos lines which doenot contain word \"TEST\" in small caps\n"
+ "this regex captures only thos lines which doenot contain word \"test\" in small caps";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}