const regex = /^((?!test).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!test).)*$', 'gm')
const str = `hello there
hello there test
testing here
we are not TEsting here
hello hi
this regex captures only thos lines which doenot contain word "TEST" in small caps
this regex captures only thos lines which doenot contain word "test" in small caps`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}