using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!test).)*$";
string input = @"hello there
hello there test
testing here
we are not TEsting here
hello hi
this regex captures only thos lines which doenot contain word ""TEST"" in small caps
this regex captures only thos lines which doenot contain word ""test"" in small caps";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}