import re
regex = re.compile(r"^((?!test).)*$", flags=re.MULTILINE)
test_str = ("hello there\n"
"hello there test\n"
"testing here \n"
"we are not TEsting here\n"
"hello hi \n"
"this regex captures only thos lines which doenot contain word \"TEST\" in small caps\n"
"this regex captures only thos lines which doenot contain word \"test\" in small caps")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")