Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((?!test).)*$
/
gm
Input 1
1
New
hello there hello there test testing here we are not TEsting here hello hi this regex captures only thos lines which doenot contain word "TEST" in small caps this regex captures only thos lines which doenot contain word "test" in small caps