re = /^((?!test).)*$/m
str = 'hello there
hello there test
testing here
we are not TEsting here
hello hi
this regex captures only thos lines which doenot contain word "TEST" in small caps
this regex captures only thos lines which doenot contain word "test" in small caps'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end