$re = '/^((?!test).)*$/m';
$str = 'hello there
hello there test
testing here
we are not TEsting here
hello hi
this regex captures only thos lines which doenot contain word "TEST" in small caps
this regex captures only thos lines which doenot contain word "test" in small caps';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);