# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\: (.*), (.*); Area/\/: \2 \1; Area\//gm;t' <<< "Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333"