// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\: (.*), (.*); Area").unwrap();
let string = "Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333";
let substitution = "/: \\2 \\1; Area/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}