use strict;
my $str = 'Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333';
my $regex = qr/\: (.*), (.*); Area/mp;
my $subst = '/: \\2 \\1; Area/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";