$re = '/\: (.*), (.*); Area/m';
$str = 'Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333';
$subst = "/: \2 \1; Area/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;