import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\: (.*), (.*); Area";
final String string = "Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567\n"
+ "Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333";
final String subst = "/: \\2 \\1; Area/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}