# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)/$1\n【$3】$2/gsm;t' <<< "第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。"