const regex = /(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(第.*?条)\\n(?:.*?)(\\d+)\\n([^\\s]+)', 'gsm')
const str = `第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。`;
const subst = `$1\n【$3】$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);